Webcam shows 3x - Updating rhel 4

I also tried on another 6.2 VM to update the subscription-manager package so that the --release option becomes available.

However, it is not possible to set a preferred operating system through Red Hat Subscription Manager on older versions of Red Hat Enterprise Linux.

The system can be restricted to a certain operating system version on Red Hat Enterprise Linux 6.2 by editing the yum configuration.

For example, to limit yum updates to 6.2-version packages: Just now -- and it didn't work.

I'm not sure why the message says package_blah.el6 will be updated, package_blah.el5will be an update.

Let's say that I have one RHEL6.2 64bit server running. Running "yum update" will update my server up to 6.4 straight away.

What if I want to update only to certain point release?

For example, I want to update RHEL6.2 server only to RHEL6.3, not to 6.4. Thanks in advance, I noticed this new workaround in the redhat KB: Red Hat Enterprise Linux 6.2 Manually Setting a Preferred Operating System Release Beginning in Red Hat Enterprise Linux 6.3, Red Hat Subscription Manager could set a preferred operating system version to use to limit automatic updates for a system.

This system is receiving updates from Red Hat Subscription Management.

This system is receiving updates from RHN Classic or RHN Satellite.

rhel-6-workstation-rhev-agent-rpms | 2.8 k B rhel-6-workstation-rpms | 3.8 k B Setting up Update Process Resolving Dependencies -- Finished Dependency Resolution Error: Package: python-mako-0.3.5-1.el5noarch (rpmforge) Requires: python(abi) = 2.4 Installed: python-2.6.6-36.el6.x86_64 (@anaconda-Red Hat Enterprise Linux-201301301459.x86_64/6.4) python(abi) = 2.6 Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Error: Package: python-paramiko-1.7.6-1.el5noarch (rpmforge) Requires: python(abi) = 2.4 Installed: python-2.6.6-36.el6.x86_64 (@anaconda-Red Hat Enterprise Linux-201301301459.x86_64/6.4) python(abi) = 2.6 Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Error: Package: python-beaker-1.5.3-1.el5noarch (rpmforge) Requires: python(abi) = 2.4 Installed: python-2.6.6-36.el6.x86_64 (@anaconda-Red Hat Enterprise Linux-201301301459.x86_64/6.4) python(abi) = 2.6 Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Error: Package: python-markupsafe-0.11-1.el5x86_64 (rpmforge) Requires: python(abi) = 2.4 Installed: python-2.6.6-36.el6.x86_64 (@anaconda-Red Hat Enterprise Linux-201301301459.x86_64/6.4) python(abi) = 2.6 Available: python-2.6.5-3.el6.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.5-3.el6_0.2.i686 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-20.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_2.2.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 Available: python-2.6.6-29.el6_3.3.x86_64 (rhel-6-workstation-rpms) python(abi) = 2.6 I'm not sure what is going on or where to start in tracking down the issue.

I think there may be a problem with a repository in /etc/yum.repos.d/.

Tags: , ,